Отправка бэкапов MikroTik на почту

В прошлой статье мы рассмотрели основные виды резервного копирования на Микротик (RouterOS). Итого у нас есть системный backup и экспорт конфигурации. Сегодня мы поговорим немного об автоматизации данного процесса и отправку созданных бэкапов на email.

Предположим, что у нас не один девайс, а несколько и со всех них нам бы хотелось иметь резервную копию как бинарного вида, так и экспорта. Встроенными графическими средствами нам автоматизации не добиться, будем использовать простенький скрипт. Для примера я возьму обычный CHR 6.48.2.

Настройка отправки почты

Для начала нужно указать какую почту и сервер smtp мы будем использовать для отправки. Перейдём в Tools – E-Mail:

  • Server – сервер отправки сообщений;
  • Port – порт в нашем случае smtp сервера;
  • Start TLS – Yes;
  • From и User – задаём email с которого будет осуществляться отправка.
Если вы хотите углубить свои знания по работе с роутерами MikroTik, то наша команда рекомендует пройти курсы которые сделаны на основе MikroTik Certified Network Associate и расширены автором на основе опыта . Подробно читайте ниже.

Настройка яндекс почты Mikrotik

Отправим тестовое сообщение самому себе командой:

/tool e-mail send to=mikrotiklab@yandex.ru from=mikrotiklab@yandex.ru body=test

Тестовая отправка писем RouterOS

Автоматизация резервного копирования

Как я говорил ранее, встроенных графических утилит для подобной задачи в RouterOS нет. Но мы будем использовать скрипт, который работает по следующему алгоритму:

  1. Задаёт глобальную переменную для системного бэкапа. По сути, генерирует имя из SystemID, даты, времени;
  2. Задаёт глобальную переменную для экспорта, аналогично п. 1;
  3. Создаёт бинарный бэкап без шифрования с именем из п. 1;
  4. Экспортирует конфиг с именем из п. 2;
  5. Отправляет письмо с бинарником;
  6. Отправляет письмо с экспортом;
  7. Удаляет созданные файлы резервных копий.

Наше дело добавить скрипт в System – Scripts.

Сам скрипт:

:local backupfile ([/system identity get name] ."-" . [:pick [/system clock get date] 7 11] ."-" . [:pick [/system clock get date] 0 3] ."-" . [:pick [/system clock get date] 4 6] . ".backup");
:local exportfile ([/system identity get name] ."-" . [:pick [/system clock get date] 7 11] ."-" . [:pick [/system clock get date] 0 3] ."-" . [:pick [/system clock get date] 4 6] . ".rsc");
/system backup save dont-encrypt=yes name=$backupfile;
:delay 5;
/export file=$exportfile;
:delay 5;
:local date [/system clock get date];
:local body1 "$date Mikrotik backup";
:local body2 "$date Mikrotik export";
/tool e-mail send to="mikrotiklab@yandex.ru" body="$body1" subject="$body1" file=$backupfile;
:delay 5;
/tool e-mail send to="mikrotiklab@yandex.ru" body="$body2" subject="$body2" file=$exportfile;
:delay 5;
/file remove $backupfile;
/file remove $exportfile;
:log warning "backup, export e-mail finished";

Создание скриптов на Mikrotik

Запустим его из консоли:

/system script run Backup

Запускаем скрипт из консоли

В процессе работы создадутся в корне flash 2 файла. После отправки на e-mail они удаляться. Проверим почту.

Смотрим на результат работы

К сожалению, вложение двух файлов в одно письмо я не осилил, как сделать, поэтому сделал отдельными. Если будут предложения, пишите их в комментариях.

Последним этапом зашедулим данный скрипт через планировщик в удобное для нас время.

Создание заданий планировщика автоматического бэкапа

По заданным параметрам, задание будет стартовать каждый день в 23:00.

Исправление ошибок

В процессе написания данной статьи я столкнулся с ошибкой аутентификации при отправке писем. В логах были вот такие события. Я сначала подумал, что пароль не верный, сменил, не помогло. Далее стал ковырять tool – e-mail, убрал поле from, пытался всячески отправлять через терминал разными вариациями – не помогло.

Не отправляется почта с RouterOS

Решается оно довольно просто, но не логично. В настройках почтового ящика нужно включить поддержку протокола POP.Включение POP на яндекс почта

После чего, письма отправляются без проблем.

И так, в данной статье вы узнали как настроить на MikroTik автоматическую отправку созданных Backup email. Если вам понравился материал можете паставить 5 звезд и написать в комментариях слова благодарности:).

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдёте для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

Оцените статью
MikroTikLab
Добавить комментарий

Adblock
detector